Naprawa błędu w PhpMyAdmin na PHP 7.2 (plugin_interface.lib.php)

Warning in ./libraries/plugin_interface.lib.php#551
 count(): Parameter must be an array or an object that implements Countable

Pojawia się to przy próbie importu lub eksportu.


W pliku

/usr/share/phpmyadmin/libraries/plugin_interface.lib.php

mamy taki blok kodu:

$no_options = true;
        if ($options != null && count($options) > 0) {
            foreach ($options->getProperties()
                as $propertyMainGroup
            ) {

wygląda an to, że w PHP 7.2 nie można używac count() ani sizeof() na elementach które nie są tablicami.
zmieniamy więc

if ($options != null && count((array)$options) > 0) {

zapisuje i błedu już nie ma 🙂

 

 

Zaczerpnięte z https://medium.com/@chaloemphonthipkasorn/%E0%B9%81%E0%B8%81%E0%B9%89-bug-phpmyadmin-php7-2-ubuntu-16-04-92b287090b01

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *